#include <IRhRdkDecalSupportPlugIn.h>
◆ ~IRhRdkDecalSupport()
virtual IRhRdkDecalSupport::~IRhRdkDecalSupport |
( |
| ) |
|
|
inlinevirtual |
◆ EVF()
virtual void* IRhRdkDecalSupport::EVF |
( |
const wchar_t * |
, |
|
|
void * |
|
|
) |
| |
|
pure virtual |
Emergency virtual function for future expansion.
◆ Initialize()
Called when there is no data on an object and custom parameter values need to be set to their initial values.
- Parameters
-
section | is the parameter section to be initialized. |
- Returns
- true if initialized successfully, else false.
◆ OnEditProperties()
virtual bool IRhRdkDecalSupport::OnEditProperties |
( |
IRhRdk_XMLSection & |
section | ) |
const |
|
pure virtual |
◆ SupportsEditProperties()
virtual bool IRhRdkDecalSupport::SupportsEditProperties |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- true if you support editing of custom decal properties.