Rhino C++ API  8.6
Public Member Functions | Protected Member Functions | List of all members
IRhRdkParamBlock::IIterator Class Referenceabstract

#include <RhRdkAutomaticUI.h>

Public Member Functions

virtual void DeleteThis (void)=0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual bool Next (OUT ON_wString &sParamName, OUT CRhRdkVariant &vParamValue)=0
 

Protected Member Functions

virtual ~IIterator ()
 

Constructor & Destructor Documentation

◆ ~IIterator()

virtual IRhRdkParamBlock::IIterator::~IIterator ( )
inlineprotectedvirtual

Member Function Documentation

◆ DeleteThis()

virtual void IRhRdkParamBlock::IIterator::DeleteThis ( void  )
pure virtual

◆ EVF()

virtual void* IRhRdkParamBlock::IIterator::EVF ( const wchar_t *  ,
void *   
)
pure virtual

◆ Next()

virtual bool IRhRdkParamBlock::IIterator::Next ( OUT ON_wString sParamName,
OUT CRhRdkVariant vParamValue 
)
pure virtual

Get the next parameter from the collection.

Returns
true on success, false if no more parameters.