Rhino C++ API
8.17
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
IRhRdkSafeFrame Member List
This is the complete list of members for
IRhRdkSafeFrame
, including all inherited members.
ActionFrameLinked
(void) const =0
IRhRdkSafeFrame
pure virtual
ActionFrameOn
(void) const =0
IRhRdkSafeFrame
pure virtual
ActionFrameXScale
(void) const =0
IRhRdkSafeFrame
pure virtual
ActionFrameYScale
(void) const =0
IRhRdkSafeFrame
pure virtual
BeginChange
(RhRdkChangeContext cc) const =0
IRhRdkSafeFrame
pure virtual
BeginNotifyBracket
(void)=0
IRhRdkSafeFrame
pure virtual
CopyFrom
(const IRhRdkSafeFrame &sf)=0
IRhRdkSafeFrame
pure virtual
Enabled
(void) const
IRhRdkSafeFrame
inline
EndChange
(void)=0
IRhRdkSafeFrame
pure virtual
EndNotifyBracket
(void)=0
IRhRdkSafeFrame
pure virtual
EVF
(const wchar_t *, void *)=0
IRhRdkSafeFrame
pure virtual
FieldGridOn
(void) const
IRhRdkSafeFrame
inline
FieldsOn
(void) const =0
IRhRdkSafeFrame
pure virtual
IsEqual
(const IRhRdkSafeFrame &sf) const =0
IRhRdkSafeFrame
pure virtual
LiveFrameOn
(void) const =0
IRhRdkSafeFrame
pure virtual
On
(void) const =0
IRhRdkSafeFrame
pure virtual
PerspectiveOnly
(void) const =0
IRhRdkSafeFrame
pure virtual
SetActionFrameLinked
(bool b)=0
IRhRdkSafeFrame
pure virtual
SetActionFrameOn
(bool b)=0
IRhRdkSafeFrame
pure virtual
SetActionFrameXScale
(double d)=0
IRhRdkSafeFrame
pure virtual
SetActionFrameYScale
(double d)=0
IRhRdkSafeFrame
pure virtual
SetEnabled
(bool b)
IRhRdkSafeFrame
inline
SetFieldGridOn
(bool b)
IRhRdkSafeFrame
inline
SetFieldsOn
(bool b)=0
IRhRdkSafeFrame
pure virtual
SetLiveFrameOn
(bool b)=0
IRhRdkSafeFrame
pure virtual
SetOn
(bool b)=0
IRhRdkSafeFrame
pure virtual
SetPerspectiveOnly
(bool b)=0
IRhRdkSafeFrame
pure virtual
SetTitleFrameLinked
(bool b)=0
IRhRdkSafeFrame
pure virtual
SetTitleFrameOn
(bool b)=0
IRhRdkSafeFrame
pure virtual
SetTitleFrameXScale
(double d)=0
IRhRdkSafeFrame
pure virtual
SetTitleFrameYScale
(double d)=0
IRhRdkSafeFrame
pure virtual
TitleFrameLinked
(void) const =0
IRhRdkSafeFrame
pure virtual
TitleFrameOn
(void) const =0
IRhRdkSafeFrame
pure virtual
TitleFrameXScale
(void) const =0
IRhRdkSafeFrame
pure virtual
TitleFrameYScale
(void) const =0
IRhRdkSafeFrame
pure virtual
~IRhRdkSafeFrame
()
IRhRdkSafeFrame
inline
protected
virtual
Generated on Wed Mar 12 2025 13:56:16 for Rhino C++ API by
1.8.17