Rhino C++ API  8.6
Public Member Functions | Protected Member Functions | List of all members
IRhRdkSafeFrame Class Referenceabstract

#include <IRhRdkSafeFrame.h>

Public Member Functions

virtual bool ActionFrameLinked (void) const =0
 
virtual bool ActionFrameOn (void) const =0
 
virtual double ActionFrameXScale (void) const =0
 
virtual double ActionFrameYScale (void) const =0
 
virtual IRhRdkSafeFrameBeginChange (RhRdkChangeContext cc) const =0
 
virtual void BeginNotifyBracket (void)=0
 
virtual void CopyFrom (const IRhRdkSafeFrame &sf)=0
 
bool Enabled (void) const
 
virtual bool EndChange (void)=0
 
virtual void EndNotifyBracket (void)=0
 
virtual void * EVF (const wchar_t *, void *)=0
 
bool FieldGridOn (void) const
 
virtual bool FieldsOn (void) const =0
 
virtual bool IsEqual (const IRhRdkSafeFrame &sf) const =0
 
virtual bool LiveFrameOn (void) const =0
 
virtual bool On (void) const =0
 
virtual bool PerspectiveOnly (void) const =0
 
virtual void SetActionFrameLinked (bool b)=0
 
virtual void SetActionFrameOn (bool b)=0
 
virtual void SetActionFrameXScale (double d)=0
 
virtual void SetActionFrameYScale (double d)=0
 
void SetEnabled (bool b)
 
void SetFieldGridOn (bool b)
 
virtual void SetFieldsOn (bool b)=0
 
virtual void SetLiveFrameOn (bool b)=0
 
virtual void SetOn (bool b)=0
 
virtual void SetPerspectiveOnly (bool b)=0
 
virtual void SetTitleFrameLinked (bool b)=0
 
virtual void SetTitleFrameOn (bool b)=0
 
virtual void SetTitleFrameXScale (double d)=0
 
virtual void SetTitleFrameYScale (double d)=0
 
virtual bool TitleFrameLinked (void) const =0
 
virtual bool TitleFrameOn (void) const =0
 
virtual double TitleFrameXScale (void) const =0
 
virtual double TitleFrameYScale (void) const =0
 

Protected Member Functions

virtual ~IRhRdkSafeFrame ()
 

Detailed Description

This interface is deprecated and only kept for backward compatibility.

Constructor & Destructor Documentation

◆ ~IRhRdkSafeFrame()

virtual IRhRdkSafeFrame::~IRhRdkSafeFrame ( )
inlineprotectedvirtual

Member Function Documentation

◆ ActionFrameLinked()

virtual bool IRhRdkSafeFrame::ActionFrameLinked ( void  ) const
pure virtual

Returns true if the action frame X and Y scales are linked.

◆ ActionFrameOn()

virtual bool IRhRdkSafeFrame::ActionFrameOn ( void  ) const
pure virtual

Returns true if the action frame is on.

◆ ActionFrameXScale()

virtual double IRhRdkSafeFrame::ActionFrameXScale ( void  ) const
pure virtual

Returns the action frame X scale.

◆ ActionFrameYScale()

virtual double IRhRdkSafeFrame::ActionFrameYScale ( void  ) const
pure virtual

Returns the action frame Y scale.

◆ BeginChange()

virtual IRhRdkSafeFrame& IRhRdkSafeFrame::BeginChange ( RhRdkChangeContext  cc) const
pure virtual

Call this method to get a non-const object upon which you can call non-const methods. Calls to this method are counted; you must call EndChange() once for every call to BeginChange(). Please do not use const_cast or any other means of circumventing this requirement.

◆ BeginNotifyBracket()

virtual void IRhRdkSafeFrame::BeginNotifyBracket ( void  )
pure virtual

Begins a notify bracket. Only implemented in the RDK.

◆ CopyFrom()

virtual void IRhRdkSafeFrame::CopyFrom ( const IRhRdkSafeFrame sf)
pure virtual

Sets the contents of this safe frame to be the same as 'sf'.

◆ Enabled()

bool IRhRdkSafeFrame::Enabled ( void  ) const
inline

◆ EndChange()

virtual bool IRhRdkSafeFrame::EndChange ( void  )
pure virtual

◆ EndNotifyBracket()

virtual void IRhRdkSafeFrame::EndNotifyBracket ( void  )
pure virtual

Ends a notify bracket. Only implemented in the RDK.

◆ EVF()

virtual void* IRhRdkSafeFrame::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

◆ FieldGridOn()

bool IRhRdkSafeFrame::FieldGridOn ( void  ) const
inline

◆ FieldsOn()

virtual bool IRhRdkSafeFrame::FieldsOn ( void  ) const
pure virtual

Returns true if the 4x3 field grid is on.

◆ IsEqual()

virtual bool IRhRdkSafeFrame::IsEqual ( const IRhRdkSafeFrame sf) const
pure virtual

Returns true if this safe frame is equal to 'sf'.

◆ LiveFrameOn()

virtual bool IRhRdkSafeFrame::LiveFrameOn ( void  ) const
pure virtual

Returns true if the live frame is on.

◆ On()

virtual bool IRhRdkSafeFrame::On ( void  ) const
pure virtual

Returns true if the safe frame is on.

◆ PerspectiveOnly()

virtual bool IRhRdkSafeFrame::PerspectiveOnly ( void  ) const
pure virtual

Returns true if the safe frame is only displayed in perspective views.

◆ SetActionFrameLinked()

virtual void IRhRdkSafeFrame::SetActionFrameLinked ( bool  b)
pure virtual

Sets whether or not the action frame X and Y scales are linked.

◆ SetActionFrameOn()

virtual void IRhRdkSafeFrame::SetActionFrameOn ( bool  b)
pure virtual

Sets whether or not the action frame is on.

◆ SetActionFrameXScale()

virtual void IRhRdkSafeFrame::SetActionFrameXScale ( double  d)
pure virtual

Sets the action frame X scale.

◆ SetActionFrameYScale()

virtual void IRhRdkSafeFrame::SetActionFrameYScale ( double  d)
pure virtual

Sets the action frame Y scale.

◆ SetEnabled()

void IRhRdkSafeFrame::SetEnabled ( bool  b)
inline

◆ SetFieldGridOn()

void IRhRdkSafeFrame::SetFieldGridOn ( bool  b)
inline

◆ SetFieldsOn()

virtual void IRhRdkSafeFrame::SetFieldsOn ( bool  b)
pure virtual

Sets whether or not the 4x3 field grid is on.

◆ SetLiveFrameOn()

virtual void IRhRdkSafeFrame::SetLiveFrameOn ( bool  b)
pure virtual

Sets whether or not the live frame is on.

◆ SetOn()

virtual void IRhRdkSafeFrame::SetOn ( bool  b)
pure virtual

Sets the safe frame on or off.

◆ SetPerspectiveOnly()

virtual void IRhRdkSafeFrame::SetPerspectiveOnly ( bool  b)
pure virtual

Sets whether or not the safe frame is only displayed in perspective views.

◆ SetTitleFrameLinked()

virtual void IRhRdkSafeFrame::SetTitleFrameLinked ( bool  b)
pure virtual

Sets whether or not the title frame X and Y scales are linked.

◆ SetTitleFrameOn()

virtual void IRhRdkSafeFrame::SetTitleFrameOn ( bool  b)
pure virtual

Sets whether or not the title frame is on.

◆ SetTitleFrameXScale()

virtual void IRhRdkSafeFrame::SetTitleFrameXScale ( double  d)
pure virtual

Sets the title frame X scale.

◆ SetTitleFrameYScale()

virtual void IRhRdkSafeFrame::SetTitleFrameYScale ( double  d)
pure virtual

Sets the title frame Y scale.

◆ TitleFrameLinked()

virtual bool IRhRdkSafeFrame::TitleFrameLinked ( void  ) const
pure virtual

Returns true if the title frame X and Y scales are linked.

◆ TitleFrameOn()

virtual bool IRhRdkSafeFrame::TitleFrameOn ( void  ) const
pure virtual

Returns true if the title frame is on.

◆ TitleFrameXScale()

virtual double IRhRdkSafeFrame::TitleFrameXScale ( void  ) const
pure virtual

Returns the title frame X scale.

◆ TitleFrameYScale()

virtual double IRhRdkSafeFrame::TitleFrameYScale ( void  ) const
pure virtual

Returns the title frame Y scale.