Rhino C++ API
8.18
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
ON_3dmView Member List
This is the complete list of members for
ON_3dmView
, including all inherited members.
Default
()
ON_3dmView
Dump
(ON_TextLog &text_log) const
ON_3dmView
FocalBlurAperture
(void) const
ON_3dmView
FocalBlurDistance
(void) const
ON_3dmView
FocalBlurJitter
(void) const
ON_3dmView
FocalBlurMode
(void) const
ON_3dmView
FocalBlurSampleCount
(void) const
ON_3dmView
IsValid
(ON_TextLog *text_log=0) const
ON_3dmView
m_bLockedProjection
ON_3dmView
m_bShowConstructionAxes
ON_3dmView
m_bShowConstructionGrid
ON_3dmView
m_bShowConstructionZAxis
ON_3dmView
m_bShowWorldAxes
ON_3dmView
m_clipping_planes
ON_3dmView
m_cplane
ON_3dmView
m_display_mode_id
ON_3dmView
m_name
ON_3dmView
m_named_view_id
ON_3dmView
m_page_settings
ON_3dmView
m_position
ON_3dmView
m_trace_image
ON_3dmView
m_view_type
ON_3dmView
m_vp
ON_3dmView
m_wallpaper_image
ON_3dmView
ON_3dmView
()
ON_3dmView
Read
(ON_BinaryArchive &)
ON_3dmView
RenderingSize
() const
ON_3dmView
SectionBehavior
() const
ON_3dmView
SetFocalBlurAperture
(double d)
ON_3dmView
SetFocalBlurDistance
(double d)
ON_3dmView
SetFocalBlurJitter
(double d)
ON_3dmView
SetFocalBlurMode
(ON_FocalBlurModes m)
ON_3dmView
SetFocalBlurSampleCount
(unsigned int count)
ON_3dmView
SetRenderingSize
(const ON_2iSize &size)
ON_3dmView
SetSectionBehavior
(ON::ViewSectionBehavior behavior)
ON_3dmView
SetTargetPoint
(ON_3dPoint target_point)
ON_3dmView
TargetPoint
() const
ON_3dmView
Write
(ON_BinaryArchive &) const
ON_3dmView
~ON_3dmView
()
ON_3dmView
Generated on Tue Apr 8 2025 16:24:03 for Rhino C++ API by
1.8.17