Click or drag to resize

DataTree<T>.Branch Method (Int32)

Gets the list of data which belongs to the branch path at the given index.

Namespace:  Grasshopper
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public List<T> Branch(
	int index
)

Parameters

index
Type: System.Int32
Index of data to retrieve.

Return Value

Type: List<T>
Exceptions
ExceptionCondition
IndexOutOfRangeExceptionThrown if the index does not represent a valid path.
See Also