Click or drag to resize

DataTree<T>.EnsurePath Method (GH_Path)

Create a new branch with the specified path if it doesn't already exists.

Namespace:  Grasshopper
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public List<T> EnsurePath(
	GH_Path path
)

Parameters

path
Type: Grasshopper.Kernel.Data.GH_Path
Path of the branch to ensure.

Return Value

Type: List<T>
The list that belongs to the specified path.
See Also