Click or drag to resize

GH_UndoServer Methods

The GH_UndoServer type exposes the following members.

Methods
  NameDescription
Public methodAppendToDebugLog
Public methodClear
Clear both undo and redo lists.
Public methodClearRedo
Clear the undo list.
Public methodClearUndo
Clear the redo list.
Public methodMergeRecords
Attempt to merge the N most recent records into one. The name of the merged record will be identical to the name of the oldest record.
Public methodPerformRedo
Performs a single Redo step if possible and migrates the record onto the undo stack. This function may throw all kinds of exceptions, if you're calling it from a UI thread, use a Try..Catch block to prevent crashes.
Public methodPerformUndo
Performs a single Undo step when possible and migrates the record onto the redo stack. This function may throw all kinds of exceptions, if you're calling it from a UI thread, use a Try..Catch block to prevent crashes.
Public methodPushUndoRecord(GH_UndoRecord)
Add a new undo record to the undo stack, this function clears the Redo stack.
Public methodPushUndoRecord(String, GH_UndoAction)
Add a new undo record to the undo stack, this function clears the Redo stack.
Public methodRemoveRecord
Remove the record with the specified ID from the undo or redo stack.
Top
See Also