Click or drag to resize

Tracing Methods

The Tracing type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAssert(Guid)
Display a typical ASSERT dialog with stack information.
Public methodStatic memberAssert(Guid, Exception)
Display a typical assert dialog with stack information.
Public methodStatic memberAssert(Guid, String)
Display a typical assert dialog with stack information.
Public methodStatic memberAssert(Guid, String, Exception)
Display a typical assert dialog with stack information.
Public methodStatic memberDebugLogAddEntry
Add a message to the debug log. If the debug log doesn't exist yet, it will be created. This function will only work if the Grasshopper window exists. This method is threadsafe.
Public methodStatic memberDebugLogBeginBlock
Start a new block in the debug data. You must end all your own blocks. This function will only work if the Grasshopper window exists. This method is threadsafe.
Public methodStatic memberDebugLogEndBlock
Start a new block in the debug data. You must end all your own blocks. This function will only work if the Grasshopper window exists. This method is threadsafe.
Top
See Also