Click or drag to resize

Folders Properties

The Folders type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberAppDataFolder
Gets the appdata folder for Grasshopper. This folder is defined as %appdata%\Grasshopper\ and the physical uri may differ depending on Windows version.
Public propertyStatic memberAssemblyFolders
Gets a list of all the directories from which GHA assemblies are loaded. Note: this is not the same as all folders from which GHA files were loaded at startup. This list includes the default Grasshopper folders, custom GHA folders and the locations provided by Rhino.Runtime.HostUtils.GetAssemblySearchPaths(). Folders which do not contain GHA files are omitted, as are duplicate entries.
Public propertyStatic memberAutoSaveFolder
Gets the directory in windows ApplicationData that contains the Grasshopper autosave files.
Public propertyStatic memberClusterFolders
Gets a list of all the directories from which GHCLUSTER files are loaded. GHUSER files are loaded from subfolders as well.
Public propertyStatic memberCursorFolder
Gets the directory that contains the cursor files that ship with Grasshopper.
Public propertyStatic memberCustomAssemblyFolders
Gets or sets all custom assembly folders.
Public propertyStatic memberDefaultAssemblyFolder
Gets the standard directory in windows ApplicationData that contains 3rd party GHA files.
Public propertyStatic memberDefaultAssemblyFolderVersion6
Gets the standard directory in windows ApplicationData that contains 3rd party GHA files.
Public propertyStatic memberDefaultClusterFolder
Gets the standard directory in windows ApplicationData that contains GHCLUSTER files.
Public propertyStatic memberDefaultTemplateFolder
Gets the standard directory in windows ApplicationData that contains template files.
Public propertyStatic memberDefaultUserObjectFolder
Gets the standard directory in windows ApplicationData that contains GHUSER files.
Public propertyStatic memberDesktop
Gets the desktop directory of the current user profile.
Public propertyStatic memberDownloaderApplication
Gets the location where the Downloader.exe should be. If the application is not present, null is returned.
Public propertyStatic memberFileViewerApplication
Gets the location where the FileViewer.exe should be. If the application is not present, null is returned.
Public propertyStatic memberIconFolder
Gets the directory that contains the icon files that ship with Grasshopper.
Public propertyStatic memberImageStitcherApplication
Gets the location where the ImageStitcher.exe should be. If the application is not present, null is returned.
Public propertyStatic memberPluginFolder
Gets the directory that contains the Grasshopper.dll file.
Public propertyStatic memberSDKDownloaderApplication
Gets the location where the SDKDownloader.exe should be. If the application is not present, null is returned.
Public propertyStatic memberSettingsFolder
Gets the folder into which all Grasshopper settings are stored. This folder might not exist until some settings are actually saved.
Public propertyStatic memberTemplateFolders
Gets a list of all the directories from which template files are loaded. Templates are not loaded from subfolders.
Public propertyStatic memberToolsFolder Obsolete.
Gets the directory that contains the additional executables that ship with Grasshopper.
Public propertyStatic memberTutorialFiles
Gets an array of all the tutorial files. This includes all the files with the *.gh or *.ghx extension in the Tutorials folder. Subfolders are not traversed.
Public propertyStatic memberTutorialFolder
Gets the directory that contains the tutorial files that ship with Grasshopper.
Public propertyStatic memberUserObjectFolders
Gets a list of all the directories from which GHUSER files are loaded. GHUSER files are loaded from subfolders as well.
Public propertyStatic memberVersionHistoryFile
Gets the text file location where Grasshopper will save the latest version information.
Public propertyStatic memberVersionHistoryUrl
Gets the url of the version history data.
Top
See Also