Click or drag to resize

GH_Variant Properties

The GH_Variant type exposes the following members.

Properties
  NameDescription
Public property_Bool
Gets the contents of this Variant as a bool.
Public property_Complex
Gets the contents of this Variant as a complex number.
Public property_Double
Gets the contents of this Variant as a double. If the Variant is of type Integer this cast will also work.
Public property_Int
Gets the contents of this Variant as an integer.
Public property_Plane
Gets the contents of this Variant as a Plane.
Public property_Point
Gets the contents of this Variant as a Point.
Public property_String
Gets the contents of this Variant as a String. This function will work for all Variant types.
Public property_Vector
Gets the contents of this Variant as a Vector.
Public propertyIsNumeric
Gets a value indicating whether or not the Variant is a numeric type. Only Doubles and Integers are considered to be Numeric.
Public propertyType
Gets the Type of this Variant.
Top
See Also