Click or drag to resize

GH_ISerializable Interface

Every object which needs to (de)serialize itself using GH_IO methodology must implement this interface.

Namespace:  GH_IO
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public interface GH_ISerializable

The GH_ISerializable type exposes the following members.

Methods
  NameDescription
Public methodRead
This method is called whenever the instance is required to deserialize itself.
Public methodWrite
This method is called whenever the instance is required to serialize itself.
Top
See Also