Click or drag to resize

VersionNumber Structure

Represents a product version number that encodes major, minor, time and build branch information. as major.minor.yyddd.hhmmb where: yy = year of build - 2000 ddd = year day of build (1-366) hh = hour of build mm = minute of build b = branch of build

Namespace:  GH_IO
Assembly:  GH_IO (in GH_IO.dll)
Syntax
[SerializableAttribute]
public struct VersionNumber : IComparable, 
	IComparable<VersionNumber>

The VersionNumber type exposes the following members.

Constructors
  NameDescription
Public methodVersionNumber(Version)
Construct VersionNumber based on existing System.Version class.
Public methodVersionNumber(Int32, Int32, DateTime, VersionNumberBranch)
Initializes a new instance of the VersionNumber structure to the version specified by the parameters.
Public methodVersionNumber(Int32, Int32, Int32, Int32)
Initializes a new instance of the VersionNumber structure to the version specified by the version quartet values.
Top
Properties
  NameDescription
Public propertyBuildBranch
Gets the build branch component of this instance.
Public propertyIsValid
True when all information in the VersionNumber has valid values.
Public propertyMajor
Gets the major version number component of this instance.
Public propertyStatic memberMaxMajorVersionNumber
The largest possible valid value of VersionNumber.MajorVersionNumber.
Public propertyStatic memberMaxMinorVersionNumber
The largest possible valid value of VersionNumber.MinorVersionNumber.
Public propertyStatic memberMaxValid
The largest possible valid VersionNumber.
Public propertyStatic memberMaxValidBuildBranch
Represents the largest possible valid value of VersionNumber.BuildBranch. This field is read-only.
Public propertyStatic memberMaxValidTime
The largest possible valid value of VersionNumber.Time. This field is read-only.
Public propertyStatic memberMinMajorVersionNumber
The smallest possible valid value of VersionNumber.MajorVersionNumber.
Public propertyStatic memberMinMinorVersionNumber
The smallest possible valid value of VersionNumber.MinorVersionNumber.
Public propertyMinor
Gets the minor version number component of this instance.
Public propertyStatic memberMinValid
The smallest possible valid VersionNumber.
Public propertyStatic memberMinValidBuildBranch
Represents the smallest possible valid value of VersionNumber.BuildBranch. This field is read-only.
Public propertyStatic memberMinValidTime
The smallest possible valid value of VersionNumber.Time. This field is read-only.
Public propertyTime
Gets the version time component of this instance.
Public propertyStatic memberUnset
The Unset VersionNumber. VersionNumber.Unset.IsValid is false.
Public propertyStatic memberUnsetBuildBranch
The value of an Unset VersionNumber.BuildBranch.
Public propertyStatic memberUnsetTime
The value of an Unset VersionNumber.Time.
Top
Methods
  NameDescription
Public methodCompareTo(Object)
Compares the value of this instance to a specified VersionNumber value and returns an integer that indicates whether this instance is earlier than, the same as, or later than the specified VersionNumber value.
Public methodCompareTo(VersionNumber)
Compares the value of this instance to a specified VersionNumber value and returns an integer that indicates whether this instance is earlier than, the same as, or later than the specified VersionNumber value.
Public methodToString
Converts the value of the current VersionNumber object to its equivalent string representation major.minor.yyddd.hhmmb. (Overrides ValueType.ToString().)
(Overrides ValueTypeToString.)
Public methodToVersion
Convert this VersionNumber class to System.Version()
Public methodStatic memberTryParse(String, VersionNumber)
Converts the specified string representation of a version number to its VersionNumber equivalent and returns a value that indicates whether the conversion succeeded.
Public methodStatic memberTryParse(Version, VersionNumber)
Attempt so convert the System.Version representation of a version number to its VersionNumber equivalent and returns a value that indicates whether the conversion succeeded.
Top
See Also