Click or drag to resize

GH_Theme Class

Inheritance Hierarchy
SystemObject
  Grasshopper.GUI.ThemeGH_Theme

Namespace:  Grasshopper.GUI.Theme
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Theme : GH_ISerializable

The GH_Theme type exposes the following members.

Constructors
  NameDescription
Public methodGH_Theme
Create a new default theme.
Public methodGH_Theme(GH_Theme)
Make a duplicate of another theme.
Top
Properties
  NameDescription
Public propertyBackGround
Gets the theme background settings.
Public propertyStatic memberDefaultTheme
Public propertyObjects
Gets the theme objects and ZUI settings.
Public propertyPage
Gets the theme page and grid settings.
Public propertyPalettes
Gets the theme palette settings.
Public propertyWires
Gets the theme wire settings.
Top
Methods
  NameDescription
Public methodLoadTheme
Instantiate all palette and gui defaults. This function reads the colour values out of grasshopper_gui.xml settings database if it exists.
Public methodRead
Public methodSaveTheme
Store all palette and gui defaults. This function writes the colour values out to grasshopper_gui.xml settings database.
Public methodWrite
Top
See Also