Click or drag to resize

Index3dT Class

Represents an element index within a Tree3d instance.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.Geometry.SpatialTreesIndex3dT

Namespace:  Grasshopper.Kernel.Geometry.SpatialTrees
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class Index3d<T> : IComparable<Index3d<T>>

Type Parameters

T

The Index3dT type exposes the following members.

Constructors
  NameDescription
Public methodIndex3dT
Initializes a new instance of the Index3dT class
Top
Properties
  NameDescription
Public propertyGlobalIndex
Gets the item index within the tree global list.
Public propertyItem
Gets the actual item.
Public propertyLocalIndex
Gets the index within the node index list.
Public propertyNode
Gets the node of the tree in which this element is stored.
Top
Methods
  NameDescription
Public methodCompareTo
Top
See Also