Click or drag to resize

Versioning Class

Static class that provides information regarding the Grasshopper versioning.
Inheritance Hierarchy
SystemObject
  GrasshopperVersioning

Namespace:  Grasshopper
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class Versioning

The Versioning type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberBuildDate
Gets the build date string. This is the visible release iteration tag. Typically the BuildDate is just the date (MMMM-dd, yyyy), but it may carry a prefix or suffix for special builds.
Public propertyStatic memberVersion
Gets the version of the current build of Grasshopper.
Public propertyStatic memberVersionString
Gets the version of the current build of Grasshopper.
Top
Methods
  NameDescription
Public methodStatic memberSyncVersionHistoryData
Attempts to download the version history information. The downloaded data (if the download works) will eventually be stored at: Grasshopper.Folders.VersionHistoryFile
Public methodStatic memberVersionHistoryData
Gets the currently most up-to-date version history data.
Top
See Also