Description:

Initializes an instance of a dictionary for writing to a 3dm archive.

Syntax:
public ArchivableDictionary()
Available since:
5.0

Description:

Initializes an instance of a dictionary for writing to a 3dm archive.

Syntax:
public ArchivableDictionary(
int version,
string name
)
Parameters:
  • version
  • Type: int
  • custom version used to help the plug-in developer determine which version of a dictionary is being written. One good way to write version information is to use a date style integer (YYYYMMDD)
  • name
  • Type: string
  • Optional name to associate with this dictionary. NOTE: if this dictionary is set as a sub-dictionary, the name will be changed to the sub-dictionary key entry
Available since:
5.0

Description:

Initializes an instance of a dictionary for writing to a 3dm archive.

Syntax:
public ArchivableDictionary(
int version
)
Parameters:
  • version
  • Type: int
  • Custom version used to help the plug-in developer determine which version of a dictionary is being written. One good way to write version information is to use a date style integer (YYYYMMDD)
Available since:
5.0

Description:

Protected constructor for internal use.

Syntax:
protected ArchivableDictionary(
SerializationInfo info,
StreamingContext context
)
protected
Parameters:
  • info
  • Type: System.Runtime.Serialization.SerializationInfo
  • Serialization data.
  • context
  • Type: System.Runtime.Serialization.StreamingContext
  • Serialization stream.

Description:

Initializes an instance of a dictionary for writing to a 3dm archive

Syntax:
public ArchivableDictionary(
UserData parentUserData
)
Parameters:
Available since:
5.0

ArchivableDictionary constructor

Class:  Rhino.Collections.ArchivableDictionary

Nothing found