Description:

Attempts to read a Rhino plug-in's custom data from the File3dm file.

Syntax:
public bool TryRead(
File3dmPlugInData pluginData,
Func<File3dm, BinaryArchiveReader,
bool> dataReader
)
Parameters:
  • dataReader
  • Type: Func<File3dm, BinaryArchiveReader, bool>
  • The function that will read the data. This function must be implemented identical to the the originating plug-in's PlugIns.PlugIn.ReadDocument(RhinoDoc, BinaryArchiveReader, FileReadOptions) method.
Returns:
Type: bool
The value returned by the data reading function if successful, False otherwise.

Nothing found