Description:

Constructs a copy of a content hash.

Syntax:
protected NameHash(
NameHash other
)
protected
Parameters:
  • other
  • Type: NameHash
  • The other content hash to copy.

Description:

Creates a new NameHash, representing a piece of text.

Syntax:
public NameHash(
string name,
Guid parentId,
bool ignoreCase
)
Parameters:
  • name
  • Type: string
  • A name. This can be None and can refer to a non-existing path.
  • parentId
  • Type: System.Guid
  • The id of the parent layer. This is only useful with layers.
  • ignoreCase
  • Type: bool
  • All manifest searches currently ignore case, except for groups.
Available since:
6.0

Description:

Creates a new NameHash, representing a piece of text.

Syntax:
public NameHash(
string name,
Guid parentId,
ModelComponentType type
)
Parameters:
  • name
  • Type: string
  • A name. This can be None and can refer to a non-existing path.
  • parentId
  • Type: System.Guid
  • The id of the parent layer. This is only useful with layers.
  • type
  • Type: DocObjects.ModelComponentType
  • Calls DocObjects.ModelComponent.ModelComponentTypeIgnoresCase to determine if case should be used in search.
Available since:
6.0

Description:

Creates a new NameHash, representing a piece of text.

Syntax:
public NameHash(
string name,
Guid parentId
)
Parameters:
  • name
  • Type: string
  • A name. This can be None and can refer to a non-existing path.
  • parentId
  • Type: System.Guid
  • The id of the parent layer. This is only useful with layers.
Available since:
6.0

Description:

Creates a new NameHash, representing a piece of text.

Syntax:
public NameHash(
string name
)
Parameters:
  • name
  • Type: string
  • A name. This can be None and can refer to a non-existing path.
Available since:
6.0

NameHash constructor

Class:  Rhino.FileIO.NameHash

Nothing found