Arc struct

Represents the value of a plane, two angles and a radius in a sub-curve of a three-dimensional circle. The curve is parameterized by an angle expressed in radians. For an IsValid arc the total subtended angle AngleRadians() = Domain()(1) - Domain()(0) must satisfy 0 < AngleRadians() < 2*Pi The parameterization of the Arc is inherited from the Circle it is derived from. In particular t -> center + cos(t)*radius*xaxis + sin(t)*radius*yaxis where xaxis and yaxis, (part of Circle.Plane) form an orthonormal frame of the plane containing the circle.

Namespace: Rhino.Geometry
Arc: references

Nothing found