Description:

Initializes a new instance of an arc from a base circle and an angle.

Syntax:
public Arc(
Circle circle,
double angleRadians
)
Parameters:
  • circle
  • Type: Circle
  • Circle to base arc upon.
  • angleRadians
  • Type: double
  • Sweep angle of arc (in radians)
Available since:
5.0

Description:

Initializes a new instance of an arc from a base circle and an interval of angles.

Syntax:
public Arc(
Circle circle,
Interval angleIntervalRadians
)
Parameters:
  • circle
  • Type: Circle
  • Circle to base arc upon.
  • angleIntervalRadians
  • Type: Interval
  • Increasing angle interval in radians with angleIntervalRadians.Length() <= 2.0*Math.PI.
Available since:
5.0

Description:

Initializes a new arc from a base plane, a radius value and an angle.

Syntax:
public Arc(
Plane plane,
double radius,
double angleRadians
)
Parameters:
  • plane
  • Type: Plane
  • The plane of the arc (arc center will be located at plane origin)
  • radius
  • Type: double
  • Radius of arc.
  • angleRadians
  • Type: double
  • Sweep angle of arc (in radians)
Available since:
5.0

Description:

Initializes a new aligned arc at the given center point, with a custom radius and angle.

Syntax:
public Arc(
Plane plane,
Point3d center,
double radius,
double angleRadians
)
Parameters:
  • plane
  • Type: Plane
  • Alignment plane for arc. The arc will be parallel to this plane.
  • center
  • Type: Point3d
  • Center point for arc.
  • radius
  • Type: double
  • Radius of arc.
  • angleRadians
  • Type: double
  • Sweep angle of arc (in radians)
Available since:
5.0

Description:

Initializes a new horizontal arc at the given center point, with a custom radius and angle.

Syntax:
public Arc(
Point3d center,
double radius,
double angleRadians
)
Parameters:
  • center
  • Type: Point3d
  • Center point of arc.
  • radius
  • Type: double
  • Radius of arc.
  • angleRadians
  • Type: double
  • Sweep angle of arc (in radians)
Available since:
5.0

Description:

Initializes a new arc through three points. If the points are coincident or co-linear, this will result in an Invalid arc.

Syntax:
public Arc(
Point3d startPoint,
Point3d pointOnInterior,
Point3d endPoint
)
Parameters:
  • startPoint
  • Type: Point3d
  • Start point of arc.
  • pointOnInterior
  • Type: Point3d
  • Point on arc interior.
  • endPoint
  • Type: Point3d
  • End point of arc.
Available since:
5.0

Description:

Initializes a new arc from end points and a tangent vector. If the tangent is parallel with the endpoints this will result in an Invalid arc.

Syntax:
public Arc(
Point3d pointA,
Vector3d tangentA,
Point3d pointB
)
Parameters:
  • pointA
  • Type: Point3d
  • Start point of arc.
  • tangentA
  • Type: Vector3d
  • Tangent at start of arc.
  • pointB
  • Type: Point3d
  • End point of arc.
Available since:
5.0

Arc constructor

Class:  Rhino.Geometry.Arc

Nothing found