Description:

Call this method to get a Plane primitive for this mesh. If this meshes PrimitiveType is not a Rhino.Render.RenderPrimitiveType.Plane then the plane parameter is set to null.

Syntax:
public bool TryGetPlane(
out PlaneSurface plane
)
Parameters:
  • plane
  • Type: PlaneSurface
  • Gets set to the plane primitive for this object on success or None on error.
Returns:
Type: bool
Returns True if <b>PrimitiveType</b> is <b>Rhino.Render.RenderPrimitiveType.Plane</b> and the plane parameter was initialized otherwise returns false.
Available since:
5.7

TryGetPlane method

Class:  Rhino.Render.RenderPrimitive

Nothing found