IsocurveDensity

Defines the default surface isoparametric curve density for new objects.

Syntax

Rhino.IsocurveDensity ([intDensity])

Parameters

intDensity

Optional.  Number.  The isoparametric curve density to set.

Value

Description

0

No isocurves on knot-free spans.

1

One isocurve at each knot, or one isocurve on knot-free spans.

2

One isocurve at each knot, plus one isocurve between knot locations.

3

One isocurve at each knot, plus two isocurves between knot locations.

Returns

Number

If intDensity is not specified, then the current isoparametric curve density if successful.

Number

If intDensity is specified, then the previous isoparametric curve density if successful.

Null

If not successful, or on error.

Example

Dim intDensity

intDensity = Rhino.IsocurveDensity

If (intDensity <> 1) Then

Rhino.IsocurveDensity 1

End If

Also See

ShowIsocurves