BlockType

Returns the definition, or update, type of a block.

Syntax

Rhino.BlockType (strBlock)

Parameters

strBlock

Required.  String.  The name of an existing block definition.

Returns

Number

The block definition type.

Value

Description

0

Static.  The geometry for the instance definition is saved in the document, is fixed and has no connection to a source archive.

1 (Obsolete)

Embedded.  Same as Static.

2

Linked and Embedded.  The geometry for the instance definition is saved in the document.  The source archive file name and checksum information are present.

3

Linked. The geometry for this instance definition is not saved in the document that contains this instance definition. This instance definition geometry is imported from a "source archive."  The source archive file name and checksum information are present.

Null

On error.

Example

Dim strBlock, intType

strBlock = Rhino.GetString("Block name")

If Rhino.IsBlock(strBlock) Then

  intType = Rhino.BlockType(strBlock)

  Select Case intType

    Case 0  Call Rhino.Print("Static")

    Case 1  Call Rhino.Print("Embedded")

    Case 2  Call Rhino.Print("Linked and Embedded")

    Case 3  Call Rhino.Print("Linked")

  End Select

End If

Also See

IsBlock

IsBlockInstance

IsBlockInUse

IsBlockReference