Block Methods

A block is a collection of objects linked together to form a single entity. Using blocks lets you keep model size smaller by using block instances instead of copying identical geometry.

 

Method

Description

AddBlock

Adds a new block definition to the document.

BlockContainerCount

Returns the number of block definitions that contain a specified block as a nested block.

BlockContainers

Returns the names of block definitions that contain a specified block as a nested block.

BlockCount

Counts the number of block definitions in the document.

BlockDescription

Returns or sets the description of a block definition.

BlockIds

Returns the identifiers of all block definitions in the document.

BlockInstanceCount

Counts the number of instances of the block in the document.

BlockInstanceId

Returns the block definition identifier of a block instance object.

BlockInstanceInsertPoint

Returns the insertion point of a block instance.

BlockInstanceName

Returns the block name of a block instance.

BlockInstances

Returns the identifiers of block instances.

BlockInstanceXform

Returns the transformation matrix of a block instance.

BlockName

Returns the name of a block definition given the block definition's identifier.

BlockNames

Returns the names of all block definitions in the document.

BlockObjectCount

Returns the number of objects that define a block definition.

BlockObjects

Returns the identifiers of the objects that make up a block definition.

BlockPath

Returns the path to a linked block definition.

BlockStatus

Returns the status of a linked block.

BlockType

Returns the definition, or update, type of a block.

BlockURL

Returns or sets the URL of a block definition.

BlockURLTag

Returns or sets the URL description of a block definition.

DeleteBlock

Deletes a block definition and it's instances.

ExplodeBlockInstance

Explodes a block instance.

InsertBlock

Inserts a block whose definition already exists in the document.

IsBlock

Verifies that a block definition exists.

IsBlockEmbedded

Verifies that a block definition is embedded/linked from an external file.

IsBlockInstance

Verifies that an object is a block instance.

IsBlockInUse

Verifies that a block definition is being used.

IsBlockObject

Verifies that an object is a block definition object.

IsBlockReference

Verifies that a block definition is from a reference file.

RenameBlock

Renames a block definition.