IsBlockEmbedded

Verifies that a block definition is static, embedded, or linked-and-embedded.

Syntax

Rhino.IsBlockEmbedded (strBlock)

Parameters

strBlock

Required.  String.  The name or identifier of an existing block definition.

Returns

Boolean

True or false indicating success or failure.

Null

On error.

Example

Dim strBlock

strBlock = Rhino.GetString("Block name")

If Rhino.IsBlock(strBlock) Then

If Rhino.IsBlockEmbedded(strBlock) Then

Rhino.Print "The block definition is embedded."

Else

Rhino.Print "The block definition is not embedded."

End If

Else

Rhino.Print "The block definition does not exist."

End If

Also See

IsBlock

IsBlockInstance

IsBlockInUse

IsBlockReference