Returns the radius of an arc curve object.
Rhino.ArcRadius (strObject [, intIndex [, dblTolerance]])
strObject |
Required. String. The object's identifier. |
intIndex |
Optional. Number. If strObject identifies a polycurve object, then intIndex identifies the curve segment of the polycurve to query. |
dblTolerance |
Optional. Number. If the curve is not an arc curve object, then the tolerance used to determine whether or not the NURBS form of the curve has the properties of an arc. If omitted, Rhino's internal zero tolerance is used. |
Number |
The radius of the arc if successful. |
Null |
If not successful, or on error. |
Dim strObject, dblRadius
strObject = Rhino.GetObject("Select arc")
If Rhino.IsArc(strObject) Then
dblRadius = Rhino.ArcRadius(strObject)
Rhino.Print "Arc radius: " & CStr(dblRadius)
End If