The following methods are available for creating, querying or manipulating curve and polycurve objects. A polycurve is a curve that is represented by a sequence of contiguous curve segments. Generally, polycurves are created by using the Join command.
Method |
Description |
Adds an arc curve. |
|
Add a 3 point arc curve. |
|
Adds an arc curve, created from a start point, a start direction, and an end point, to the document. |
|
Creates a curve blend between two curves. |
|
Adds a circle curve. |
|
Adds a 3 point circle curve. |
|
Adds a circle curve, created from two points and a start direction, to the document. |
|
Adds a circle curve that is tangent to 2 curves to the document. |
|
Adds a circle curve that is tangent to 3 curves to the document. |
|
Adds a control points curve. |
|
Adds an elliptical curve. |
|
Adds a 3 point elliptical curve. |
|
Adds a fillet between two curve objects. |
|
Adds an interpolated curve on a surface. |
|
Adds an interpolated curve on a surface using surface uv coordinates. |
|
Adds an interpolated curve. |
|
Adds an interpolated curve similar to the InterpCrv command. |
|
Add a line curve. |
|
Adds a NURBS curve. |
|
Adds a regular polygon to the document. |
|
Adds a polyline curve. |
|
Adds a spiral or helical curve object to the document. |
|
Adds a spiral or helical curve object to the document. |
|
Adds a regular star polygon to the document. |
|
Adds a new curve based on a portion of an existing curve. |
|
Adds outline curves created from a text string to the document. |
|
Return the angle of an arc curve. |
|
Returns the center point of an arc curve. |
|
Returns the mid point of an arc curve. |
|
Returns the radius of an arc curve. |
|
Changes the degree of a curve object. |
|
Returns the center point of an circle curve. |
|
Returns the circumference of a circle curve. |
|
Returns the radius of a circle curve. |
|
Cleans up a poly curve. |
|
Closes an open curve object. |
|
Returns the orientation of a closed, planar curve. |
|
Changes the structure of a NURBS curve to a Bézier curve. |
|
Converts a curve to a polyline curve. |
|
Returns an arc length point on a curve. |
|
Returns the area of a closed planar curve. |
|
Returns the area centroid of a closed planar curve. |
|
Enables or disabled a curve object's annotation arrows. |
|
Differences two closed planar curves. |
|
Intersects two closed, planar curves. |
|
Unions two or more closed planar curves. |
|
Calculate the intersection of a curve object and a brep object. |
|
Returns the locations on two objects where they are closest to each other. |
|
Returns the parameter of the point on a curve that is closest to a test point. |
|
Returns the points generated by contouring a curve object. |
|
Returns the curvature of a curve at a parameter. |
|
Calculates the intersection of two curve objects. |
|
Returns the degree of a curve. |
|
Returns the deviation between two curves. |
|
Returns the dimension of a curve. |
|
Compares the direction of two curve objects. |
|
Tests a curve object for derivatitive, tangent, or curvature discontinuity. |
|
Returns the domain of a curve. |
|
Returns the edit points of a curve. |
|
Returns the end point of a curve. |
|
General purpose curve evaluator. |
|
Returns the point locations of all local extrema. |
|
Rounds the corners of kinked curves with arcs of a single specified radius. |
|
Returns points at which to cut a pair of curves so that a fillet fits. |
|
Returns a plane at a parameter. |
|
Returns the knot count of a curve. |
|
Returns the knots of a curve. |
|
Returns the length of a curve. |
|
Returns the mid point of a curve object. |
|
Returns the normal direction of a planar curve object. |
|
Converts a normalized curve parameter to a curve parameter. |
|
Converts a curve parameter to a normalized curve parameter. |
|
Returns a perpendicular plane at a parameter. |
|
Finds the location on a curve that is perpendicular to a test point. |
|
Returns the plane in which a planar curve lies. |
|
Returns the control points count of a curve. |
|
Returns the control points of a curve. |
|
Returns the radius of curvature at a point on a curve. |
|
Returns planar rail sweep frames at specified points on a curve. |
|
Adjusts the seam point of a closed curve. |
|
Returns the starting point of a curve. |
|
Calculates the intersection of a curve object with a surface object. |
|
Returns the tangent to a curve at a parameter. |
|
Finds the location on a curve that is tangent to a test point. |
|
Returns the weight values assigned to control points of a curve. |
|
Divides a curve into segments. |
|
Divides a curve such that the linear distance between the points is equal. |
|
Divides a curve into segments of a specified length. |
|
Returns the center point of an ellipse curve. |
|
Returns the distance from the center of an ellipse to a focus. |
|
Returns the foci of an ellipse. |
|
Returns the quadrant points of an ellipse curve. |
|
Evaluates a curve point at a parameter. |
|
Explodes one or more curve objects. |
|
Extends a curve object until it intersects other objects. |
|
Extends a curve object for a specified distance. |
|
Extends a curve to an end point. |
|
Extracts a segment curve from a polycurve object. |
|
Fairs a curve object. |
|
Adds a tangent arc between two curves and trims or extends the curves to the arc. |
|
Fits a new curve through an existing curve. |
|
Inserts a knot into a curve object. |
|
Verifies an object is an arc curve. |
|
Verifies an object is an circle curve. |
|
Verifies an object is a curve. |
|
Verifies an open curve object is closable. |
|
Verifies an object is a closed curve. |
|
Tests a curve to see if it is a conic section. |
|
Test a curve to see if it lies in a specific plane. |
|
Verifies an object is a linear curve. |
|
Verifies an object is a periodic curve. |
|
Verifies an object is a planar curve. |
|
Verifies an object is a rational NURBS curve. |
|
Verifies an object is an ellipse curve. |
|
Verifies an object is an elliptical-shaped arc curve object. |
|
Verifies an object is a line curve. |
|
Verifies an object is a NURBS curve object. |
|
Verifies a point is on a curve. |
|
Verifies a curve is a polycurve. |
|
Verifies an object is a polyline curve. |
|
Joins two or more curve objects. |
|
Fits a line through an array of points. |
|
Makes a periodic curve non-periodic. |
|
Makes a curve object periodic. |
|
Creates a mean curve from two curves. |
|
Creates a polygon mesh from a closed polyline. |
|
Offsets a curve. |
|
Offsets a curve normal to a surface. |
|
Offsets a curve on a surface. |
|
Determines the relationship between the regions bounded by two coplanar simple closed curves. |
|
Determines if two coplanar curves intersect. |
|
Determines if a point is inside of a closed curve, on a closed curve, or outside of a closed curve. |
|
Returns the number of curve segments represented by a polycurve. |
|
Returns the vertices of a polyline curve. |
|
Projects one or more curves onto one or more meshes. |
|
Projects one or more curves onto one or more surfaces or polysurfaces. |
|
Rebuilds a curve to given point count. |
|
Removes a knot from a curve. |
|
Remove short segments from a curve object. |
|
Reverses the direction of a curve object. |
|
Simplifies a curve object. |
|
Smooths a curve object. |
|
Soft edits a curve object. |
|
Splits a curve. |
|
Trims a curve. |
|
Creates curves between two open or closed input curves. |