ConvertCurveToBezier

Changes the structure of a NURBS curve to a Bézier curve.

Syntax

Rhino.ConvertCurveToBezier (strObject [, blnDelete])

Parameters

strObject

Required.  String.  The object's identifier.

blnDelete

Optional.  Boolean.  Delete the original object.  The default is to not delete the original object (False).

Returns

Array

An array of strings identifying the newly created curve objects if successful.

Null

If not successful, or on error.

Example

Dim strObject

strObject = Rhino.GetObject("Select a curve to convert to Beziers")

If Rhino.IsCurve(strObject) Then

Rhino.ConvertCurveToBezier(strObject, true)

End If

Also See

IsCurve