CurveArea

Returns that area of closed planar curves. The results are based on the current drawing units.

Syntax

Rhino.CurveArea (strObject)

Rhino.CurveArea (arrObjects)

Parameters

strObject

Required.  String.  The identifier of a closed, planar curve object.

arrObjects

Required.  Array.  An array of strings containing the identifiers of one or more closed, planar curve objects.

Returns

Array

An array of area information if successful.  The array will contain the following information:

Element

Type

Description

0

Number

The area. If more than one curve was specified, the value will be the cumulative area.

1

Number

The absolute (+/-) error bound for the area.

Null

If not successful, or on error.

Example

Const rhObjectCurve = 4

Dim strObject, arrMP

strObject = Rhino.GetObject("Select a curve", rhObjectCurve)

If Not IsNull(strObject) Then

arrMP = Rhino.CurveArea(strObject)

If IsArray(arrMP) Then

Rhino.Print "The curve area is: " & CStr(arrMP(0))

End If

End If

Also See

IsCurve

IsCurveClosed

IsCurvePlanar