CurveBooleanIntersection

Calculates the intersection of two closed, planar curves and adds the results to the document. Note, curves must be coplanar.

Syntax

Rhino.CurveBooleanIntersection (strCurveA, strCurveB [, blnDelete])

Parameters

strCurveA

Required.  String.  The identifier of the first curve object.

strCurveB

Required.  String.  The identifier of the second curve object.

blnDelete

Optional.  Boolean.  If True, then the inputs will be deleted. If not specified or False (default), then the inputs will not be deleted.

Returns

Array

The identifiers of the new objects if successful.

Null

If not successful, or on error.

Example

Dim strCurveA, strCurveB, arrResult

strCurveA = Rhino.GetObject("Select first curve", 4)

strCurveB = Rhino.GetObject("Select second curve", 4)

arrResult = Rhino.CurveBooleanIntersection(strCurveA, strCurveB)

If IsArray(arrResult) Then

  Rhino.DeleteObject strCurveA

  Rhino.DeleteObject strCurveB

End If

Also See

CurveBooleanDifference

CurveBooleanUnion