Returns the normal direction of the plane in which a planar curve object lies.
Rhino.CurveNormal (strObject)
strObject |
Required. String. The object's identifier. |
Array |
The 3-D normal vector if successful. |
Null |
If not successful, or on error. |
Dim strObject, arrNormal
strObject = Rhino.GetObject("Select a planar curve")
If Rhino.IsCurve(strObject) And Rhino.IsCurvePlanar(strObject) Then
arrNormal = Rhino.CurveNormal(strObject)
If IsArray(arrNormal) Then
Rhino.Print "Curve Normal: " & Rhino.Pt2Str(arrNormal)
End If
End If