FilletCurves

Adds a tangent arc between two curves and trims or extends the curves to the arc. Note, unlike Rhino's Fillet command, this method does not modify the input curve objects.

Syntax

Rhino.FilletCurves (strCurve0, arrPoint0, strCurve1, arrPoint1, dblRadius [, blnJoin [, blnTrim [, blnArcExtension]]])

Parameters

strCurve0

Required.  String.  The identifier of the first curve object to fillet.

arrPoint0

Required.  Array.  A 3-D point on the first curve that is near the end where the fillet will be added.

strCurve1

Required.  String.  The identifier of the second curve object to fillet.

arrPoint1

Required.  Array.  A 3-D point on the second curve that is near the end where the fillet will be added.

dblRadius

Required.  Number.  The fillet radius.

blnJoin

Optional.  Boolean.  Joins the resulting curves. The default is False.

blnTrim

Optional.  Boolean.  Trims the input curves to the resulting fillet curve. The default is True.

blnArcExtension

Optional.  Boolean.  This is applies when arcs are filleted or chamfered but need to be extended to meet the fillet curve or chamfer line. If True (Default) then the arc is extended maintaining its validity. If False, then the arc is extended with a line segment, which is joined to the arc converting it to a polycurve.

Returns

Array

The identifiers of the newly added curve objects if successful. The number of identifiers and the types of curve objects depends on the input curves and the values of the parameters that were used during the fillet operation. In most cases, the output array will contain either one or three identifiers, although two identifiers can be returned if dblRadius = 0 and blnJoin = false. For example, if both blnJoin and blnTrim = True, then the identifier will reference a polycurve, containing the fillet curve joined with trimmed copies of the input curves. If blnJoin = False and blnTrim = True, then the identifiers of three curves, the fillet curve and trimmed copies of the input curves, will be returned. If both blnJoin and blnTrim = False, then just the identifier of the fillet curve is returned.

Null

On error.

Example

Const rhObjectCurve = 4

Dim arrGet0, arrGet1, arrResult

arrGet0 = Rhino.GetObjectEx("Select first curve to fillet", rhObjectCurve)

arrGet1 = Rhino.GetObjectEx("Select second curve to fillet", rhObjectCurve)

arrResult = Rhino.FilletCurves(arrGet0(0), arrGet0(3), arrGet1(0), arrGet1(3), 1.0, True)

If IsArray(arrResult) Then

  Call Rhino.DeleteObject(arrGet0(0))

  Call Rhino.DeleteObject(arrGet1(0))

End If