IsCircle

Verifies an object is a circle curve object or is a NURBS curve object that looks like a circle.

Syntax

Rhino.IsCircle (strObject [, dblTolerance]))

Parameters

strObject

Required.  String.  The object's identifier.

dblTolerance

Optional.  Number.  If the curve is not a circle curve object, then the tolerance used to determine whether or not the NURBS form of the curve has the properties of a circle. If omitted, Rhino's internal zero tolerance is used.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject("Select a circle")

If Rhino.IsCircle(strObject) Then

Rhino.Print "The object is a circle."

Else

Rhino.Print "The object is not a circle."

End If

Also See

AddCircle

AddCircle3Pt

CircleCenterPoint

CircleCircumference

CircleRadius