IsNurbsCurve

Verifies an object is a NURBS curve object.

Syntax

Rhino.IsNurbsCurve (strObject [, intIndex])

Parameters

strObject

Required.  String.  The object's identifier.

intIndex

Optional. Number. If strObject identifies a polycurve object, then intIndex identifies the curve segment of the polycurve to query.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject("Select a curve")

If Rhino.IsNurbsCurve(strObject) Then

  Rhino.Print "The object is a NURBS curve."

Else

  Rhino.Print "The object is not a NURBS curve."

End If

Also See

AddNurbsCurve

IsCurve