IsPointOnCurve

Verifies that a point is on a curve.

Syntax

Rhino.IsPointOnCurve (strObject, arrPoint [, intIndex [, dblTolerance]])

Parameters

strObject

Required. String. The object's identifier.

arrPoint

Required.  Array.  The test, or sampling, point.

arrPoint

Optional. Number. If strObject identifies a polycurve object, then intIndex identifies the curve segment of the polycurve to query.

dblTolerance

Optional.  Number.  A tolerance to test against. Of omitted, Rhino's internal tolerance is used.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Dim strObject, arrPoint

strObject = Rhino.GetObject("Select a curve")

If Rhino.IsCurve(strObject) Then

arrPoint = Rhino.GetPoint("Pick a test point")

If IsArray(arrPoint) Then

If Rhino.IsPointOnCurve(strObject, arrPoint) Then

Rhino.Print "The point is on the curve"

Else

Rhino.Print "The point is not on the curve"

End If

End If

End If

Also See

IsCurve