OffsetCurveNormal

Offsets a curve, that lies on a surface, normal to the surface. This is functionally similar to the OffsetNormal command.

Syntax

Rhino.OffsetCurveNormal (strSurface, strCurve, dblDistance)

Parameters

strSurface

Required.  String.  The identifier of the base surface object.

strCurve

Required.  String.  The identifier of the curve, that lies on the surface, to offset.

dblDistance

Required.  Number.  The distance to offset.

Returns

String

The identifier of the new curve object if successful.

Null

If not successful, or on error.

Example

Dim strSurface, strCurve

strCurve = Rhino.GetObject("Select curve to offset normal to surface", 4)

strSurface = Rhino.GetObject("Select base surface", 8)

Rhino.OffsetCurveNormal strSurface, strCurve, 5.0

Also See

OffsetCurve

OffsetCurveOnSurface