RemoveShortCurveSegments

Remove short segments from a curve object. Note, this does not change the curve's domain, but it will change the relative parameterization.

Syntax

Rhino.RemoveShortCurveSegments (strObject, dblTolerance)

Parameters

strObject

Required.  String.  The identifier of the curve object.

dblTolerance

Required.  Number.  The tolerance.  If < 0 (Default), then an appropriate tolerance is automatically calculated. If == 0, then Rhino's internal zero tolerance is used. If > 0, then the input value is used.

Returns

Boolean

True if short segments were both detected and removed, False otherwise.

Null

On error.

Example

Const rhObjectCurve = 4

Dim strObject

strObject = Rhino.GetObject("Select curve for short segment removal", rhObjectCurve)

If Not IsNull(strObject) Then

  Rhino.RemoveShortCurveSegments strObject

End If

Also See

IsCurve