Returns the names of all dimension styles in the document.
Rhino.DimStyleNames ([blnSort [, blnIncludeChildStyles]])
blnSort |
Optional. Boolean. Return a sorted list of dimension style names. The default is not to return a sorted list (False). |
blnIncludeChildStyles |
Optional. Boolean. Include child dimension styles. A child dimension styles is created when a dimension style, assigned to a dimension object, is overridden. |
Array |
An array of dimension style names if successful. |
Null |
If not successful, or on error. |
Dim arrDimStyles, strDimStyle
arrDimStyles = Rhino.DimStyleNames
If IsArray(arrDimStyles) Then
For Each strDimStyle In arrDimStyles
Rhino.Print strDimStyle
Next
End If