Home > RhinoScript Methods > Dimension Methods

Show Navigation Component

Dimension Methods

The following methods are available for querying or manipulating dimension styles and dimension objects.

 

Method

Description

AddAlignedDimension

Adds an aligned dimension object.

AddDimStyle

Adds a new dimension style.

AddLeader

Adds an annotation leader object.

AddLinearDimension

Adds a linear dimension object.

AddRadialDimension

Adds a radial dimension object.

CurrentDimStyle

Returns or sets the currently active dimension style.

DeleteDimStyle

Deletes a dimension style.

DimensionStyle

Returns or modifies the style of a dimension object.

DimensionText

Returns the display text of a dimension object.

DimensionUserText

Returns or modifies the user text string of a dimension object.

DimensionValue

Returns the value of a dimension object.

DimStyleAnglePrecision

Returns or modifies the angle display format of a dimension style.

DimStyleArrowSize

Returns or modifies the arrowhead size of a dimension style.

DimStyleCentermarkSize

Returns or modifies the center mark size of a dimension style.

DimStyleCount

Returns the number of dimension styles.

DimStyleDimLineExtension

Returns or modifies the dimension line extension of a dimension style.

DimStyleExtension

Returns or modifies the extension line extension of a dimension style.

DimStyleFieldOverride

Returns or modifies the overridden state of a field of a child dimension style.

DimStyleFont

Returns or modifies the font used by a dimension style.

DimStyleLeaderArrowSize

Returns or modifies the leader arrowhead size of a dimension style.

DimStyleLengthFactor

Returns or modifies the length factor of a dimension style.

DimStyleLinearPrecision

Returns or modifies the linear precision of a dimension style.

DimStyleNames

Returns all dimension style names.

DimStyleNumberFormat

Returns or modifies the number display format of a dimension style.

DimStyleOffset

Returns or modifies the extension line offset of a dimension style.

DimStylePrefix

Returns or modifies the prefix of a dimension style.

DimStyleScale

Returns or modifies the scale of a dimension style.

DimStyleSuffix

Returns or modifies the suffix of a dimension style.

DimStyleTextAlignment

Returns or modifies the text alignment of a dimension style.

DimStyleTextGap

Returns or modifies the text gap of a dimension style.

DimStyleTextHeight

Returns or modifies the text height of a dimension style.

IsAlignedDimension

Verifies an object is an aligned dimension.

IsAngularDimension

Verifies an object is an angular dimension.

IsDiameterDimension

Verifies an object is a diameter dimension.

IsDimension

Verifies an object is a dimension.

IsDimStyle

Verifies a dimension style exists.

IsDimStyleChild

Verifies that a dimension style is a child dimension style.

IsDimStyleReference

Verifies a dimension style is from a reference file.

IsLeader

Verifies an object is a dimension leader object.

IsLinearDimension

Verifies an object is a linear dimension.

IsOrdinateDimension

Verifies an object is an ordinate dimension.

IsRadialDimension

Verifies an object is a radial dimension.

LeaderText

Returns or modifies a leader object's text string.

ParentDimStyle

Returns the name of a child dimension style's parent dimension style.

RenameDimStyle

Renames a dimension style.