Returns or sets the document's modified flag. The modified flag indicates whether or not any changes to the current document have been made.
Note, setting the document modified flag to false will prevent the "Do you want to save this file..." from displaying when you close Rhino.
Rhino.DocumentModified ([blnModified])
blnModified |
Optional. Boolean. The modified state, either True or False. |
Boolean |
If no modified state is specified, the current modified state if successful. |
Boolean |
If a modified state is specified, the previous modified state if successful. |
Dim blnModified
blnModified = Rhino.IsDocumentModified
If blnModified = False Then
Rhino.DocumentModified(True)
End If