Document Methods

The following methods are available for querying or manipulating the currently active 3DM document.

 

Method

Description

CreatePreviewImage

Creates a preview image from the current model.

DocumentInfo

Returns summary information about a document.

DocumentModified

Returns or sets the document's modified flag.

DocumentName

Returns or sets the current document name.

DocumentPath

Returns the path of the currently loaded document.

DocumentURL

Returns the URL assigned to the current document.

EnableModelSpaceHatchScale

Enables or disables model space hatch scaling.

EnableModelSpaceTextScale

Enables or disables model space text scaling.

EnableRedraw

Enables or disables screen redrawing.

ExtractPreviewImage

Extracts a preview image from a specified model.

IsDocumentModified

Verifies that the current document has been modified

ModelSpaceHatchScale

Returns or sets the model space hatch scale factor.

ModelSpaceLinetypeScale

Returns or sets the model space linetype scale factor.

ModelSpaceTextScale

Returns or sets the model space text scale factor.

Notes

Returns or sets the document's notes.

ReadFileVersion

Return file version of the current document.

Redraw

Redraws all views.

RenderAntialias

Returns or sets the anti-aliasing style.

RenderColor

Returns or sets render colors.

RenderMeshDensity

Returns or sets the render mesh density parameter.

RenderMeshMaxAngle

Returns or sets the render mesh maximum angle parameter.

RenderMeshMaxAspectRatio

Returns or sets the render mesh maximum aspect ratio parameter.

RenderMeshDistEdgeToSrf

Returns or sets the render mesh distance edge to surface parameter.

RenderMeshMaxEdgeLength

Returns or sets the render mesh maximum edge length parameter.

RenderMeshMinEdgeLength

Returns or sets the render mesh minimum edge length parameter.

RenderMeshMinInitialGridQuads

Returns or sets the render mesh minimum initial grid quads parameter.

RenderMeshQuality

Returns or sets the render mesh quality parameter.

RenderMeshSettings

Returns or sets the render mesh settings.

RenderResolution

Returns or set the render resolution.

RenderSettings

Returns or sets render settings.

UnitAbsoluteTolerance

Returns or sets the model absolute tolerance.

UnitAngleTolerance

Returns or sets the model angle tolerance.

UnitCustomUnitSystem

Sets a custom model unit system.

UnitDistanceDisplayMode

Returns or sets the model distance display mode.

UnitDistanceDisplayPrecision

Returns or sets the model distance display precision.

UnitRelativeTolerance

Returns or sets the model relative tolerance.

UnitScale

Returns the scale factor for changing unit systems.

UnitSystem

Returns or sets the model unit system.

UnitSystemName

Returns the name of the current model unit system.

WorkSessionFileName

Returns the path to the open worksession file.

WorkSessionModelAliases

Returns the aliases of the models used by the worksession.

WorkSessionModelCount

Returns the number of models in the worksession.

WorkSessionModelNames

Returns the paths to the models used by the worksession.