Returns the name of the current unit system.
Rhino.UnitSystemName ([blnCapitalize [, blnSingular [, blnAbbreviate [, blnModelUnits]]]])
blnCapitalize |
Optional. Boolean. Capitalize the first character of the units system name (e.g. return "Millimeter" instead of "millimeter"). The default is not to capitalize the first character (false). |
blnSingular |
Optional. Boolean. Return the singular form of the units system name (e.g. "millimeter" instead of "millimeters"). The default is to return the singular form of the name (true). |
blnAbbreviate |
Optional. Boolean. Abbreviate the name of the units system (e.g. return "mm" instead of "millimeter"). The default is not to abbreviate the name (false). |
blnModelUnits |
Optional. Boolean. Return the document's model units (True) or the document's page units (False). The default is True. |
String |
The name of the current units system if successful. |
Dim strSystem
strSystem = Rhino.UnitSystemName(False, False, False)
Rhino.Print "The units system is set to " & strSystem