Returns or modifies the clip view or views of a clipping plane object.
Rhino.ClippingPlaneView (strObject [, strView])
Rhino.ClippingPlaneView (strObject [, arrViews])
strObject |
Required. String. The object's identifier. |
strView |
Optional. String. The title or identifier of the new view to clip. Note, to remove all clipped view, specify Null. |
arrViews |
Optional. Array. The titles or identifiers of the new views to clip. Note, to remove all clipped views, specify Null. |
Array or Empty |
If strView or arrViews is not specified, the identifiers of the current clipped view if successful. Note, if the clipping plane has no clipped views, Empty is returned. |
Array or Empty |
If strView or arrViews is specified, the identifiers of the previous clipped view if successful. Note, if the clipping plane has no clipped views, Empty is returned. |
Null |
If not successful, or on error. |
Dim strObject, strView
strObject = Rhino.GetObject("Select clipping plane", &h20000000)
If Not IsEmpty(strObject) Then
strView = Rhino.CurrentView
Call Rhino.ClippingPlaneView(strObject, strView)
End If