Geometry Methods

The following methods are available for creating, querying or manipulating miscellaneous geometric objects.  For methods relating to curve objects, see Curve Methods.  For methods relating to surface and polysurface objects, see Surface and Polysurface Methods.  For methods relating to mesh objects, see Mesh Methods.

 

Method

Description

AddClippingPlane

Adds a clipping plane.

AddPictureFrame

Adds a picture frame object to the document.

AddPoint

Adds a point object.

AddPointCloud

Adds a point cloud object.

AddPoints

Adds one or more point objects.

AddText

Adds a text object.

AddTextDot

Adds an annotation text dot object

BoundingBox

Returns the bounding box of objects.

CircleFromPoints

Creates a circle fit from points.

ClippingPlaneDefinition

Returns or modifies the underlying plane of a clipping plane object.

ClippingPlaneView

Returns or modifies the clipped views of a clipping plane object.

CompareGeometry

Determines if two objects are geometrically identical.

FlipClippingPlane

Reverses the direction of a clipping plane object.

IsClippingPlane

Verifies an object is a clipping plane.

IsKnotVectorClamped

Verifies that a knot vector is clamped.

IsKnotVectorPeriodic

Verifies that a knot vector is periodic.

IsKnotVectorUniform

Verifies that a knot vector is uniform.

IsPictureFrame

Verifies that an object is a picture frame object.

IsPoint

Verifies an object is a point object.

IsPointCloud

Verifies an object is a point cloud object.

IsText

Verifies an object is a text object.

IsTextDot

Verifies an object is a text dot object.

KnotVectorHasBezierSpans

Verifies that all knots in a knot vector have multiplicity equal to degree.

KnotVectorStyle

Returns the style of a knot vector.

PointCloudCount

Returns the number of points in a point cloud.

PointCloudHasHiddenPoints

Verifies that a point cloud object has hidden points.

PointCloudHasPointColors

Verifies that a point cloud object has point colors.

PointCloudHidePoints

Returns or modifies the hidden points of a point cloud object.

PointCloudPointColors

Returns or modifies the point colors of a point cloud object.

PointCloudPoints

Returns the points of a point cloud.

TextDotFont

Returns or modifies the font of a text dot object.

TextDotHeight

Returns or modifies the text height of a text dot object.

TextDotPoint

Returns or modifies the location of an annotation text dot object.

TextDotText

Returns or modifies the text string of an annotation text dot object.

TextObjectFont

Returns or modifies the font of a text object.

TextObjectFormula

Returns or modifies the formula of a text object.

TextObjectHeight

Returns or modifies the text height of a text object.

TextObjectJustification

Returns or modifies the justification of a text object.

TextObjectMask

Returns or set the mask of a text object.

TextObjectPlane

Returns or modifies the plane of a text object.

TextObjectPoint

Returns or modifies the location of a text object.

TextObjectStyle

Returns or modifies the font style of a text object.

TextObjectText

Returns or modifies the text string of a text object.