Returns the points of a point cloud object.
Rhino.PointCloudPoints (strObject)
strObject |
Required. String. The identifier of a point cloud object. |
Array |
An array of 3-D points if successful. |
Null |
If not successful, or on error. |
Const rhObjectPointCloud = 2
Dim strObject, arrPoints, arrPoint
strObject = Rhino.GetObject("Select point cloud", rhObjectPointCloud)
arrPoints = Rhino.PointCloudPoints(strObject)
If IsArray(arrPoints) Then
For Each arrPoint in arrPoints
Rhino.Print Rhino.Pt2Str(arrPoint, 3)
Next
End If