Returns or modifies the X, Y, and Z coordinates of a point object.
Rhino.PointCoordinates (strObject [, arrPoint])
strObject |
Required. String. The identifier of a point object. |
arrPoint |
Optional. Array. A new 3-D point location. |
Array |
If arrPoint is not specified, the current 3-D point location if successful. |
Array |
If arrPoint is specified, the previous 3-D point location if successful. |
Null |
If not successful, or on error. |
Const rhObjectPoint = 1
Dim strObject, arrPoint
strObject = Rhino.GetObject("Select point", rhObjectPoint)
arrPoint = Rhino.PointCoordinates(strObject)
If IsArray(arrPoint) Then
Rhino.Print Rhino.Pt2Str(arrPoint, 3)
End If