GetGroupUserText

Returns user text that is stored on a group. For more details on User Text, see the discussion found in the User Data Methods summary.

Syntax

Rhino.GetGroupUserText (strGroup [, strKey])

Parameters

strGroup

Required.  String.  The name or identifier of an existing group.

strKey

Optional.  String.  The key name.  If omitted or an empty string ("") is specified, all key names for the layer are returned.

Returns

String

If strKey is specified, then the associated value if successful.

Array

If strKey is not specified, then an array of key names if successful.

Null

If not successful, or on error.

Example

Dim arrObjects, strObject

For Each strObject in arrObjects

  Rhino.Print Rhino.GetGroupUserText(strObject, "TestKey")

Next

Also See

SetGroupUserText