HatchArea

Returns that area of hatches. The results are based on the current drawing units.

Syntax

Rhino.HatchArea (strObject)

Rhino.HatchArea (arrObjects)

Parameters

strObject

Required.  String.  The identifier of a hatch object.

arrObjects

Required.  Array.  An array of strings containing the identifiers of one or more hatch objects.

Returns

Array

An array of area information if successful.  The array will contain the following information:

Element

Type

Description

0

Number

The area. If more than one hatch was specified, the value will be the cumulative area.

1

Number

The absolute (+/-) error bound for the area.

Null

If not successful, or on error.

Example

Const rhHatch = &h10000

Dim strObject, arrMP

strObject = Rhino.GetObject("Select a hatch", rhHatch)

If Not IsNull(strObject) Then

arrMP = Rhino.HatchArea(strObject)

If IsArray(arrMP) Then

Rhino.Print "The hatch area is: " & CStr(arrMP(0))

End If

End If

Also See

IsHatch