The following methods are available for adding, querying or manipulating hatch patterns and hatch objects.
Method |
Description |
Creates a new hatch object from a closed, planar curve. |
|
Creates one or more hatch objects from closed, planar curves. |
|
Imports hatch pattern from a pattern file. |
|
Returns the name of the current hatch pattern. |
|
Duplicates the border curves of a hatch object. |
|
Explodes a hatch object into its component objects. |
|
Returns the area of a hatch object. |
|
Returns the hatch pattern name from a hatch object. |
|
Returns the number of hatch patterns in the current document. |
|
Returns the description of a hatch pattern. |
|
Returns the fill type of a hatch pattern. |
|
Returns the names of the hatch patterns in the current document. |
|
Returns or modifies the hatch pattern rotation of a hatch object. |
|
Returns or modifies the hatch pattern scale of a hatch object. |
|
Verifies that an object is a hatch object. |
|
Verifies that a hatch pattern exists in the current document. |
|
Verifies that a hatch pattern is the current hatch pattern. |
|
Verifies that a hatch pattern is from a reference file. |